2007 Endeavor - Multiple Misfires - Mitsubishi-Forums.com
LinkBack Thread Tools
post #1 of 2 (permalink) Old 12-02-2011, 05:41 PM Thread Starter
Join Date: May 2008
Location: 19001
Posts: 13
2007 Endeavor LS AWD - 82k Miles

I recently had both check engine and tcl lights come on solid a day after a 65 mile trip through rain ice, and bad weather. Accompanying these lights on is a rough idle at low idling rpm's and vehicle shaking at higher ones when I tried to drive it. There is 1/2 tank of 91 gas and the gas cap is locked tight. I checked the oil and it was fine, I added fuel injector cleaner along with dry gas and ran the vehicle about 15 miles. None of this seemed to help. I took the vehicle to Autozone and had them read the error code for me which was P0300. The autozone person further said it was a Cyl #4 misfire. I took the vehicle to a repair shop and they ran a diagnostic. They proceeded to change out the coil on cyl #4 and a new error code showed up identifying a misfire in cyl. #6. They checked all the plugs and wires and found no problems. There was no evidence of a manifold gasket leak either. The timing belt on the vehicle has not yet been changed. After this they stopped and said I should take it to a dealer who has better diagnostics to identify the problem. I am concerned about what could be wrong. I have read alot and seems like most of the usual suspects have been eliminatedas the cause of the issue. Any help before I take this to a dealer would be greatly appreciated.
jameo is offline  
Sponsored Links
post #2 of 2 (permalink) Old 12-20-2011, 05:57 PM
Join Date: May 2005
Posts: 18
it is p0300 which is multiple misfire, this could be many things, I do not think so that is related to cylinder , in my opinion it is electrical/sensor/airflow problem. I have same problem/code and looking into it.
Check MASS AIRFLOW SENSOR (intake air flow temperature sensor), this could be your and mine problem.Looking to find how to test this sensor. I red on internet about this.
PedjaC is offline  

Quick Reply

Register Now

In order to be able to post messages on the Mitsubishi-Forums.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome