07 endeavor start? - Mitsubishi-Forums.com
 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 02-13-2017, 11:10 AM Thread Starter
Newbie
 
Join Date: Feb 2017
Posts: 3
Unhappy 07 endeavor start?

my wifes endeavor died. well first off she noticed a faint dinging from under then dash when she shut the car off. Now she goes out yesterday and tried to start it and she said it just made a chattering noise like the battery was dead. I went out this morning and looked at it and to hook up a charger. well I noticed a lot of corrosion on the + post so I took it apart cleaned it and noticed the cable end was eaten away so I went and picked up another end. installed it and tried jumping the car well there is all dash lights and tested voltage and it's at 12.6 turned the key to crank and the voltage didn't drop. ANY IDEA'S?
GRUMPYPAPA is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 02-13-2017, 12:00 PM
Super Moderator
 
Join Date: Oct 2008
Location: Alberta
Posts: 1,051
Take battery to a shop that can test it for amperage.


Audio: JVC KD-ABT22 / JL sub+speakers / Sound deadening
Engine: WR-SRI / RRM 25% UDP / 6G75 TB
Other: RA Mudflaps
izerous is offline  
post #3 of 7 (permalink) Old 02-13-2017, 01:08 PM Thread Starter
Newbie
 
Join Date: Feb 2017
Posts: 3
Just got back took the battery out and had it tested 79% battery life remaing and 100% charged and enough amperage almost 600 cca
GRUMPYPAPA is offline  
 
post #4 of 7 (permalink) Old 02-13-2017, 03:03 PM
Super Moderator
 
Join Date: Oct 2008
Location: Alberta
Posts: 1,051
Alternator isn't an issue at this point as with a good battery it should still start and run just not run for long. Does it make noise as though the starter motor is actually trying to turn over? If the starter is turning and trying to spin the engine I'd turn my attention maybe towards fuel pumps, spark plugs etc.


Audio: JVC KD-ABT22 / JL sub+speakers / Sound deadening
Engine: WR-SRI / RRM 25% UDP / 6G75 TB
Other: RA Mudflaps
izerous is offline  
post #5 of 7 (permalink) Old 02-13-2017, 03:33 PM Thread Starter
Newbie
 
Join Date: Feb 2017
Posts: 3
Its not cranking the starter at all. I'm thinking starter at this point.
GRUMPYPAPA is offline  
post #6 of 7 (permalink) Old 02-13-2017, 05:41 PM
Super Moderator
 
Join Date: Oct 2008
Location: Alberta
Posts: 1,051
Check wiring to starter with a meter as well before blindly replacing it.


Audio: JVC KD-ABT22 / JL sub+speakers / Sound deadening
Engine: WR-SRI / RRM 25% UDP / 6G75 TB
Other: RA Mudflaps
izerous is offline  
post #7 of 7 (permalink) Old 02-14-2017, 01:07 AM
Super Moderator
 
xrxaa01's Avatar
 
Join Date: Feb 2011
Location: Tanauan City
Posts: 1,153
Chattering noise could be the starter trying to push the gear onto flywheel gear.

I would test for that.

If it is that - I would take starter apart - clean thoroughly - grease solenoid
(the part that pushes the gear onto flywheel) etc. and try.
xrxaa01 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mitsubishi-Forums.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome