Galant 6a12 Manual- Chassis Vibration When Accelerating. -
LinkBack Thread Tools
post #1 of 1 (permalink) Old 11-26-2012, 01:27 AM Thread Starter
tw2005's Avatar
Join Date: Sep 2008
Location: Ipswich
Posts: 474
I've been having bad chassis vibration above 80kmh and worsens with acceleration. really bad at 100kmh and on long trip unbearable going up hills.

I concluded long ago it was driveline and possibly driveshaft inner joints.

Finally found some shafts and replaced them both.

Final result is all fixed and caused by bad inner RHS shaft inner joint.

Attached Images
File Type: jpg IMG_0009.JPG (1.04 MB, 5 views)
File Type: jpg IMG_0010.JPG (935.3 KB, 6 views)
File Type: jpg IMG_0011.JPG (915.0 KB, 6 views)
tw2005 is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome