2001 Galant 2.4 Not Starting - Mitsubishi-Forums.com
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 10-02-2010, 04:51 PM Thread Starter
Newbie
 
Join Date: Jun 2009
Posts: 3
Thumbs up

I was driving and it just shut off. I have gas pressure but no spark. I think it could be the cam sensor but before I spend 60 bucks I was wondering if I should look at any other possibilities. Also the starter and battery are in great working order.
ohio2001g is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 10-02-2010, 07:35 PM
Veteran
 
SRSONE's Avatar
 
Join Date: Jun 2008
Location: naples,fl
Posts: 4,032
need more...

does it crank?
does it sound like it wants to start?

any codes?

any noises when it shut off?

the more u give us the better...

I am a rocker, I am a roller, I am an out of controller!
the nightrider


What the **** is an aluminum falcon?
SRSONE is offline  
post #3 of 5 (permalink) Old 10-02-2010, 09:49 PM Thread Starter
Newbie
 
Join Date: Jun 2009
Posts: 3
does it crank? Yes, but doesn't try to fire at all.
does it sound like it wants to start? No, it just keeps cranking

any codes? I have no way of reading the codes unless I spend 50 bucks just to get it to a shop. What hand held will give you a code, everyone I have talked to says They don't do that. Only a repair shop can get codes?

any noises when it shut off? When I stop cranking it there is no sound at all.

the more u give us the better... I removed the fuel hose from the gas tank to see if I had a fuel pump issue and it was good then I checked for spark on no.2 and no.4 and nothing. I was going to check to see if I am getting 12 volts at the coil packs but it started to rain and I gave up and had to watch the Buckeyes, so tomorrow I will check for that and try to find somewhere online to order a cam sensor for a decent price and can get it to me sooner than all the auto part stores. Hard to believe but no national auto part stores carry this part, but a couple said they will now knowing that this seems to be a common problem with car. My only fear is if my timing belt jumped or computer failed. The car was running perfect before this happened and with now warning it just shut off and when I turned the key it just cranked with no fire on any cylinders. What sucks is I just spent a week replacing a freeze plug on the rear of the block with out removing anything off the block and only using one hand and flushing the coolant, and it ran better than it ever has.
ohio2001g is offline  
post #4 of 5 (permalink) Old 10-02-2010, 10:00 PM
Super Moderator
 
KiT TeUnG 2549's Avatar
 
Join Date: May 2008
Location: Houston , Texas
Posts: 3,962
Send a message via Yahoo to KiT TeUnG 2549
In most cases when the cam sensor fails this is juss it , it stops. Its a wide known issues on USDM models. yu can check the coils for fire , alhto yu say there is no spark/ignition fire frum the coil.

You Look Like I Need Another Drink
KiT TeUnG 2549 is offline  
post #5 of 5 (permalink) Old 12-23-2010, 11:02 PM
Newbie
 
Join Date: Sep 2007
Posts: 15
I just replaced my cam sensor a couple months ago in my 2001 2.4. Had the exact problem too. Luckily mine slowly went out. Bought it from Advance Auto Parts. Paid 30 bucks because I found a coupon code to order it online and picked up in store. Autozone also had the part. You may want to try ebay and similar sites as well.
elkypro is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mitsubishi-Forums.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome