2003 Galant Es not starting after aftermarket stereo installation - Mitsubishi-Forums.com
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 02-15-2017, 08:50 PM Thread Starter
Newbie
 
Join Date: Feb 2017
Posts: 2
2003 Galant Es not starting after aftermarket stereo installation

So this is a used a car I bought from a private seller almost a year ago. Recently the factory stereo started failing so I decided to install a new one and tried doing it myself. I got the correct harness for the sound system (it has the infinity setup) and put it all together last night.

There were two antenna wires and I couldn't use the smaller wire so I just wrapped it in electrical tape and let it be. There was a long black grounding wire that came attached the new stereo's harness and I attached that underneath a bolt that I think is just attached to the chassis so I'm hoping that's not where the trouble is from. Anyway I had the negative terminal disconnected while I was doing all this.

I reconnect it and everything is working great. The car starts running when I turn the key and the new radio is playing music. Then the lights start to go dim and everything dies.

I go to the battery and find that the negative terminal had become detached while I had the car running. It was a little loose to begin with so I wasn't surprised. I reattach it and try to start the car again but it won't start. Just makes this clicking noise from the area around the ecu and fuses.

Also the headlights are flashing and if I open a door the door ajar light on the instrument panel starts to flash as well as the dome the car. When I turn the key to the on position some of the instrument panel the way nothing happens. When I turn the key to try and start it there is absolutely nothing. No sound, no cranking, no anything.

At this point I'm wondering if I activated the electronics immobilizer? Or some kind of at this point alarm system? I don't think the battery is dead because when I first reconnect the battery the headlights will come on. They seem strong and after I open the door or start messing with it is when they start flashing. I'm bringing it in to a repair shop tomorrow but there are no Mitsubishi dealers anywhere near me so I'm not able to get it into a dealer.

Also I cleaned the negative battery terminal and post and attached a shim post so it's not loose anymore and that didn't change anything.

Last edited by chain rattle; 02-15-2017 at 08:52 PM.
Freshesh is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-16-2017, 07:57 AM
Newbie
 
Join Date: Aug 2016
Posts: 16
Garage
check grounds and fuses I put an aftermarket radio in mine too and I grounded something wrong. so go through your wiring and just double check also try and see if unplugging the new harness for the radio and see if the car starts.
justin1319 is offline  
post #3 of 4 (permalink) Old 02-16-2017, 11:26 AM
Super Moderator
 
Join Date: Oct 2008
Location: Alberta
Posts: 1,058
It does sound like something is shorted out or the battery was almost dead and you finished it off.


Audio: JVC KD-ABT22 / JL sub+speakers / Sound deadening
Engine: WR-SRI / RRM 25% UDP / 6G75 TB
Other: RA Mudflaps
izerous is offline  
 
post #4 of 4 (permalink) Old 02-24-2017, 03:26 PM Thread Starter
Newbie
 
Join Date: Feb 2017
Posts: 2
It turned out to be the battery, it was pretty old and it must have been failing. I had a new battery installed and it works fine now.
Freshesh is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mitsubishi-Forums.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome