Outside brake lights stopped working, middle one fine - Mitsubishi-Forums.com
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 04-19-2017, 10:30 AM Thread Starter
Newbie
 
Join Date: Apr 2017
Posts: 1
Question Outside brake lights stopped working, middle one fine

Hi there,

I've got a 2006 mitsubishi galant SE and my left and right brake lights stopped working. The middle one comes on fine. Ive checked fuses and replaced both bulbs and still nothing. Where should i be looking here???
amattson815 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-20-2017, 12:35 AM
Super Moderator
 
xrxaa01's Avatar
 
Join Date: Feb 2011
Location: Tanauan City
Posts: 1,213
Connector.

Probably one for both brake lights and all the other lights left and right.

Corroded pin will do that.

If not connector - broken wire - long search.

Try narrowing it down with multimeter - voltage yes or no.
xrxaa01 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mitsubishi-Forums.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome