2010 mitubish lancer 2.4L engine tick - Mitsubishi-Forums.com
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 03-09-2017, 09:33 PM Thread Starter
Newbie
 
Join Date: Mar 2017
Posts: 1
2010 mitubish lancer 2.4L engine tick

Has anyone had a louder than normal tick coming from passanger side valve cover [above timing chain] area. Tick starts around 1500-2000rpms, and continues throughout 4k? Iv pulled valve cover off, looked at the chain for slack, checked cam & lobes everything looks good. I even had mitubishi diag it and they came back with no result. No codes have came on, and iv pretty much came to the end of the road without pulling the chain, and cams and checking the lifters. Has anyone had this problem, or have a possible solution. I have videos if anyone needs a idea of whats up.
Preston Friend is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-09-2017, 11:53 PM
Super Moderator
 
Join Date: Oct 2008
Location: Alberta
Posts: 1,058
Valve lash needing adjusting is the most common ticking noise.


Audio: JVC KD-ABT22 / JL sub+speakers / Sound deadening
Engine: WR-SRI / RRM 25% UDP / 6G75 TB
Other: RA Mudflaps
izerous is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mitsubishi-Forums.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome