Welcome Guest ( Log In | Register )

Mitsubishi-Forums.com > Mitsubishi Models > Eclipse Forum > 3G (2000-2005) Eclipse
Mitsubishi-Forums.com - The UNOFFICIAL Mitsubishi Community This site is NOT affiliated in any way with Mitsubishi or any of it's subsidiaries. Our goal is to provide Mitsubishi owners an information outlet - a means to communicate with other Mitsubishi owners. It is simply a community where fans and owners can get the right information for tuning, customization and general discussions on anything about Mitsubishi. You'll find the answer to almost any question about your Mitsubishi in this site. If not, simply join and ask! We have many willing expert members just waiting to answer your questions.

Mitsubishi-Forums.com is not affiliated with or endorsed by Mitsubishi Motors.
 
Reply to this topicStart new topic

Do you like Mitsubishi-Forums.com? Link to us and help spread the word about our forum. Thanks!
> 03 Eclispe Heating Problem
fisher4550
post Dec 25 2012, 09:02 PM
Post #1


Newbie


Group: Members
Posts: 5
Joined: 16-June 10
Member No.: 90,714
Status: Offline
Location: USA
Drives: 2003 Mitsubishi Eclispe Gs



I have a 2003 eclispe, and the heat worked very well in it. Now when I start the car and let it warm up the heat gets warm enough to defrost the windows but not warm like it use too. If you idle the car at a high rpm the heat gets warm or if you start driving it, the air gets warmer. I was wondering if anyone else has had this problem with this car and if so what is wrong with it?
Go to the top of the page
 
QuoteReply
SRSONE
post Dec 26 2012, 08:30 AM
Post #2


Veteran
*****

Group: Members
Posts: 4,026
Joined: 19-June 08
Member No.: 59,794
Status: Offline
Location: USA
Drives: 2007 OUTLANDER ES with the v6 and the 6 speed(no flappy paddles),2001 kia rio,1979 chevy k20 stepside



have you started with the basics?

check the coolant level? is it full? has it been changed like its supposed to be?

have you flushed the system and replaced the coolant recently?

do all the doors and settings work correctly?
Go to the top of the page
 
QuoteReply
Akorna
post Jan 5 2014, 05:47 PM
Post #3


Newbie


Group: Members
Posts: 13
Joined: 16-October 08
Member No.: 66,020
Status: Offline
Location: USA
Drives: 2003 Eclipse



bad thermostat? No thermostat? malfunctioning heater controls? Blower working?
Go to the top of the page
 
QuoteReply
KiT TeUnG 2549
post Jan 28 2014, 08:14 PM
Post #4


Veteran
Group Icon

Group: Super Mod
Posts: 3,783
Joined: 21-May 08
Member No.: 58,134
Status: Offline
Location: San Sai , Chiang Mai ,TH
Drives: 1997 Mitsubishi Diamante VR-S SUPER INVECS II , 1990 Mitsubishi Galant VR4 MR, 2006 Mitsubishi Triton PLUS 3.5 DOCH , 2001 Mitsubishi Galant GSR



Coolant level low/leak , blocked /restricted heater core , HVAC blend door issues
Go to the top of the page
 
QuoteReply
  Advanced Search
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Mitsubishi listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Pinned: 03 Outlander No Heat? Here's The Fix.
2 mikevegas06 55 16th October 2014 - 06:28 AM
Last post by: mikevegas06
No New Posts 03 Petrol Space Star Wont Start. Arghhhhhhhhhhhhh
i hate it
1 fedupwithmumsspacestar 477 21st June 2014 - 04:24 PM
Last post by: chain rattle
No New Posts Problem With Rear Hatch Glass Lock
5 DavidE 456 3rd March 2014 - 12:28 PM
Last post by: KiT TeUnG 2549
No New Posts Pinned: Topic has attachments03 Lancer Timing Belt
replacement tips
2 emujo 42,515 11th June 2013 - 03:48 PM
Last post by: Bluelancer2
No New Posts 03 Rear Drum Brakes
Conversion to disk?
3 brunoboy650 481 6th February 2013 - 02:25 AM
Last post by: brunoboy650

 
 
 
Time is now: 24th October 2014 - 07:42 AM
Mitsubishi-Forums.com is not affiliated with or endorsed by Mitsubishi Motors.
Privacy Statement