Welcome Guest ( Log In | Register )

Mitsubishi-Forums.com > Mitsubishi Models > Montero, Challenger, Pajero & Shogun Forum
Mitsubishi-Forums.com - The UNOFFICIAL Mitsubishi Community This site is NOT affiliated in any way with Mitsubishi or any of it's subsidiaries. Our goal is to provide Mitsubishi owners an information outlet - a means to communicate with other Mitsubishi owners. It is simply a community where fans and owners can get the right information for tuning, customization and general discussions on anything about Mitsubishi. You'll find the answer to almost any question about your Mitsubishi in this site. If not, simply join and ask! We have many willing expert members just waiting to answer your questions.

Mitsubishi-Forums.com is not affiliated with or endorsed by Mitsubishi Motors.
 
Reply to this topicStart new topic

Do you like Mitsubishi-Forums.com? Link to us and help spread the word about our forum. Thanks!
> Eratic Temperature Gauge
goatah
post Sep 23 2006, 07:39 AM
Post #1


Newbie


Group: Members
Posts: 1
Joined: 24-June 06
Member No.: 25,775
Status: Offline
Location: usa
Drives: 2001 Mitsubishi Montero xls



I own a 2001 Montero, and recently the temperature gauge started acting up. I immediately replaced the thermostat, which wasn't the problem. I took it in to the shop, and they replaced the temperature sensor. Five minutes after leaving the shop, the temp gauge pegged to Hot again, and then immediately back down. The shop tells me that temps are normal when hooked to the scanner, even when it's pegged on hot. They kept it for a day to run some tests, but are dumfounded. They don't know what the problem is, or how to rectify it. Please help.

Thanks,
Matt
Go to the top of the page
 
QuoteReply
manybrews
post Sep 23 2006, 07:47 AM
Post #2


Mitsu tech. For a LONG time.
****

Group: Members
Posts: 1,159
Joined: 7-February 06
Member No.: 20,898
Status: Offline
Location: USA
Drives: 97 diamante.



if the engine is indeed NOT overheating, your issue is probably a failing instrument cluster ECM. Ive dealt with that issue a few times in the past.

first thing to do is 100 percent verify that the car is not overheating.

it is NOT normal for the gauge to move when a scan tool is plugged in.
Go to the top of the page
 
QuoteReply
jamess
post Oct 20 2008, 12:54 PM
Post #3


Newbie


Group: Members
Posts: 1
Joined: 20-October 08
Member No.: 66,187
Status: Offline
Location: france
Drives: pajero 3.2d



I have a 2001 Pajero 3.2 D with the same problem - did you solve yours?
Go to the top of the page
 
QuoteReply
kristinnsam
post Dec 2 2008, 05:45 PM
Post #4


Newbie


Group: Members
Posts: 1
Joined: 28-September 07
Member No.: 45,800
Status: Offline
Location: iceland
Drives: 2001 Mitshubishi Pajero GLX



QUOTE (jamess @ Oct 20 2008, 01:54 PM) *
I have a 2001 Pajero 3.2 D with the same problem - did you solve yours?


Had the exact problem on my 2001 Pajero 3.2 did GLX that you have. First I replaced the thermostat, Then the temp. sender unit, but the problem remained. Then I cheked the waterpump, borrowed another radiator. Finally took the instrument cluster and replaced it with another from 2003 Pajero 3.2 did, and finally the problem is solved. I assume that the problem is in the temerature gauge.

Check this out, http://www2.pajeroclub.com.au/forum/showthread.php?t=3014
Go to the top of the page
 
QuoteReply
  Advanced Search
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Mitsubishi listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Temperature Switch Problem
1 EnZo420 467 24th May 2012 - 11:52 AM
Last post by: somebody
No New Posts Temperature For Thermostat To Open
attention "Chain rattle"
1 jhale101 964 7th January 2011 - 11:03 AM
Last post by: KiT TeUnG 2549
No New Posts Temperature Gauge
2 bluestone120 1,010 31st December 2010 - 10:38 AM
Last post by: KiT TeUnG 2549
No New Posts Gauge Cluster Evo X On Lancer Gts
4 alvaro_vd79 478 1st December 2010 - 08:44 PM
Last post by: jRox
No New Posts Gauges,color?
1 Mrwip3m3down67 452 27th October 2010 - 04:15 AM
Last post by: cptbbb

 
 
 
Time is now: 21st December 2014 - 02:29 PM
Mitsubishi-Forums.com is not affiliated with or endorsed by Mitsubishi Motors.
Privacy Statement