Welcome Guest ( Log In | Register )

Mitsubishi-Forums.com > Mitsubishi Models > Galant Forum > 8G (1999-2003) Galant
Mitsubishi-Forums.com - The UNOFFICIAL Mitsubishi Community This site is NOT affiliated in any way with Mitsubishi or any of it's subsidiaries. Our goal is to provide Mitsubishi owners an information outlet - a means to communicate with other Mitsubishi owners. It is simply a community where fans and owners can get the right information for tuning, customization and general discussions on anything about Mitsubishi. You'll find the answer to almost any question about your Mitsubishi in this site. If not, simply join and ask! We have many willing expert members just waiting to answer your questions.

Mitsubishi-Forums.com is not affiliated with or endorsed by Mitsubishi Motors.
 
Reply to this topicStart new topic

Do you like Mitsubishi-Forums.com? Link to us and help spread the word about our forum. Thanks!
> 2001 Galant 2.4 Not Starting
ohio2001g
post Oct 2 2010, 03:51 PM
Post #1


Newbie


Group: Members
Posts: 3
Joined: 16-June 09
Member No.: 73,464
Status: Offline
Location: Mansfield, Ohio
Drives: 2001 Mitsubishi Galant ES



I was driving and it just shut off. I have gas pressure but no spark. I think it could be the cam sensor but before I spend 60 bucks I was wondering if I should look at any other possibilities. Also the starter and battery are in great working order.
Go to the top of the page
 
QuoteReply
SRSONE
post Oct 2 2010, 06:35 PM
Post #2


Veteran
*****

Group: Members
Posts: 4,026
Joined: 19-June 08
Member No.: 59,794
Status: Offline
Location: USA
Drives: 2007 OUTLANDER ES with the v6 and the 6 speed(no flappy paddles),2001 kia rio,1979 chevy k20 stepside



need more...

does it crank?
does it sound like it wants to start?

any codes?

any noises when it shut off?

the more u give us the better...
Go to the top of the page
 
QuoteReply
ohio2001g
post Oct 2 2010, 08:49 PM
Post #3


Newbie


Group: Members
Posts: 3
Joined: 16-June 09
Member No.: 73,464
Status: Offline
Location: Mansfield, Ohio
Drives: 2001 Mitsubishi Galant ES



does it crank? Yes, but doesn't try to fire at all.
does it sound like it wants to start? No, it just keeps cranking

any codes? I have no way of reading the codes unless I spend 50 bucks just to get it to a shop. What hand held will give you a code, everyone I have talked to says They don't do that. Only a repair shop can get codes?

any noises when it shut off? When I stop cranking it there is no sound at all.

the more u give us the better... I removed the fuel hose from the gas tank to see if I had a fuel pump issue and it was good then I checked for spark on no.2 and no.4 and nothing. I was going to check to see if I am getting 12 volts at the coil packs but it started to rain and I gave up and had to watch the Buckeyes, so tomorrow I will check for that and try to find somewhere online to order a cam sensor for a decent price and can get it to me sooner than all the auto part stores. Hard to believe but no national auto part stores carry this part, but a couple said they will now knowing that this seems to be a common problem with car. My only fear is if my timing belt jumped or computer failed. The car was running perfect before this happened and with now warning it just shut off and when I turned the key it just cranked with no fire on any cylinders. What sucks is I just spent a week replacing a freeze plug on the rear of the block with out removing anything off the block and only using one hand and flushing the coolant, and it ran better than it ever has.
Go to the top of the page
 
QuoteReply
KiT TeUnG 2549
post Oct 2 2010, 09:00 PM
Post #4


Veteran
Group Icon

Group: Super Mod
Posts: 3,778
Joined: 21-May 08
Member No.: 58,134
Status: Offline
Location: San Sai , Chiang Mai ,TH
Drives: 1997 Mitsubishi Diamante VR-S SUPER INVECS II , 1990 Mitsubishi Galant VR4 MR, 2006 Mitsubishi Triton PLUS 3.5 DOCH , 2001 Mitsubishi Galant GSR



In most cases when the cam sensor fails this is juss it , it stops. Its a wide known issues on USDM models. yu can check the coils for fire , alhto yu say there is no spark/ignition fire frum the coil.
Go to the top of the page
 
QuoteReply
elkypro
post Dec 23 2010, 11:02 PM
Post #5


Newbie


Group: Members
Posts: 13
Joined: 15-September 07
Member No.: 45,165
Status: Offline
Location: usa
Drives: 2001 Galant ES 4-cyl



I just replaced my cam sensor a couple months ago in my 2001 2.4. Had the exact problem too. Luckily mine slowly went out. Bought it from Advance Auto Parts. Paid 30 bucks because I found a coupon code to order it online and picked up in store. Autozone also had the part. You may want to try ebay and similar sites as well.
Go to the top of the page
 
QuoteReply
  Advanced Search
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Mitsubishi listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts 2001 Eclipse-right Front Shock/strut Tower Broke Away.
strut is against hood
2 bob whalen 60 23rd September 2014 - 10:10 AM
Last post by: KiT TeUnG 2549
No New Posts Topic has attachmentsGalant 2003 Won't Start
15 zoso0 397 22nd September 2014 - 01:04 AM
Last post by: xrxaa01
No New Posts Pinned: Galant (legnum) 6a13 Stumble/acceleration Problem
20 smashingly 363 11th September 2014 - 11:08 PM
Last post by: chain rattle
No New Posts 2001 Tranmission Sluggish
15 Shanemc 615 28th July 2014 - 04:39 PM
Last post by: chain rattle
No New Posts 2001 Gs - Can't Shift Into 2nd
3 Stan Jarensky 102 23rd June 2014 - 09:45 AM
Last post by: KiT TeUnG 2549

 
 
 
Time is now: 23rd October 2014 - 08:44 AM
Mitsubishi-Forums.com is not affiliated with or endorsed by Mitsubishi Motors.
Privacy Statement