2003 Outlander Won't Start - Mitsubishi-Forums.com
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 05-03-2017, 09:30 AM Thread Starter
Newbie
 
Join Date: May 2017
Posts: 1
2003 Outlander Won't Start

I have a 2003 Outlander that stopped running a few days ago. Before it stopped running, it would sputter when I first started it. There were no codes on the OBD2. I replaced the fuel pump and noticed a blown fuse. I have replaced the fuse, but it keeps blowing them. It still will not start. If anyone has any suggestions, I would appreciate it. Thank you.
arjgreene is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-03-2017, 12:08 PM
Super Moderator
 
Join Date: Oct 2008
Location: Alberta
Posts: 1,653
Probably an electrical short if it is constantly blowing fuses. What is the fuse for?


Audio: JVC KD-ABT22 / JL sub+speakers / Sound deadening
Engine: WR-SRI / RRM 25% UDP / 6G75 TB
Other: RA Mudflaps
izerous is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mitsubishi-Forums.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome