Evo 8 with abs problem - Mitsubishi-Forums.com
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 08-16-2019, 06:54 PM Thread Starter
Newbie
 
Join Date: Aug 2019
Posts: 1
Evo 8 with abs problem

Hi
I have an Evo 8 2004 with abs light on, it's been making a nasty noise when I brake, brakes have been changed, a
Since the light came on the noise seems to have stopped. Diagnostic reader was plugged in, said L/H rear sensor faulty, has been changed, light still on, reader now says R/H rear sensor faulty.
We were wondering if the sensor unit is faulty?
Has anyone come across this.
Any help gratefully received
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mitsubishi-Forums.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome