93 Colt VIsta 1.8 bogging down when cold. - Mitsubishi-Forums.com
 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 05-02-2017, 06:29 PM Thread Starter
Newbie
 
Join Date: Mar 2017
Posts: 5
93 Colt VIsta 1.8 bogging down when cold.

Hi guys. I previously posted my issues regarding poor acceleration and it turned out to be the coil. Replaced it and the car runs beautifully smooth with good acceleration once it warms up. When it is cold. (I'm in Florida!), the car starts okay but after about 10 seconds, the idle starts to pulse down and up and has no power. It is like it is "loading up" and I have to back off the throttle and it catches. It's like the choke is stuck but I don't think this car has a choke as such. How does it compensate for a cold engine? How does it modify the fuel/air mixture for cold start? Again, wait five minutes for the temp gauge to come up to normal and the car runs great? Thanks ... Bob in Florida
Bob Hart is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-06-2017, 01:11 AM
Super Moderator
 
xrxaa01's Avatar
 
Join Date: Feb 2011
Location: Tanauan City
Posts: 1,402
On a carb model it would have a device on carb to enrich fuel for cold engine.

FI engine would use temp sensor and ECU to enrich fuel - more gas through injectors.

Check wiring - and OBD II codes.
xrxaa01 is offline  
post #3 of 7 (permalink) Old 05-07-2017, 09:52 AM Thread Starter
Newbie
 
Join Date: Mar 2017
Posts: 5
Thanks for the reply. This car is pre OBDII. I have read the codes with analog voltmeter. The check engine light has been on and off and I discovered yesterday that the car runs and idles fine when the light is off. Yesterday , I started the car and the check engine light was off. Idle was fine and I pulled away with no hesitation. A few minutes later, before the engine reached normal op temperature, the light came on and the hesitation came at the same time. Once the engine reached normal temperature, car ran smooth. I'm getting closer!
Bob Hart is offline  
 
post #4 of 7 (permalink) Old 05-08-2017, 01:39 AM
Super Moderator
 
xrxaa01's Avatar
 
Join Date: Feb 2011
Location: Tanauan City
Posts: 1,402
Well could be OBD I then ...

Seems temp related - ignition maybe ?

Check distributor.
xrxaa01 is offline  
post #5 of 7 (permalink) Old 05-09-2017, 12:10 PM Thread Starter
Newbie
 
Join Date: Mar 2017
Posts: 5
Thanks for the reply. New distributor cap and rotor,new fuel pump and filter, new plugs, ran Seafoam twice through fuel. Car sat for a year before I bought it. Fuel and tank are clean however previous owner started the car after it had been sitting with od fuel. Fuel pump failed, he replaced it but left the old fuel strainer on it and the pump failed again after I bought it. Fuel strainer was disintegrating. I suspect some junk may have made it into the fuel line. I replaced pump and screen but I suspect I have one or more injectors that may be intermittent. I can't think of anything else that would turn the check engine light on and at the same time reduce power and effect idle?
Bob Hart is offline  
post #6 of 7 (permalink) Old 05-09-2017, 10:38 PM
Super Moderator
 
xrxaa01's Avatar
 
Join Date: Feb 2011
Location: Tanauan City
Posts: 1,402
Well if possible take out injector and see if spray pattern looks good.

If not you need new ones cos they are clogged.
xrxaa01 is offline  
post #7 of 7 (permalink) Old 07-01-2019, 07:51 AM
Newbie
 
Join Date: Jul 2019
Posts: 4
Retard timing to around 16 BTDC then move a till you find your sweet spot mines around 13 BTDC and I got power speed all from a tiny wee 1.5
Lancer964g15 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mitsubishi-Forums.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome