Odd intrument readings on my 95 - Mitsubishi-Forums.com
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 04-24-2019, 09:24 PM Thread Starter
Newbie
 
Join Date: Aug 2018
Posts: 10
Odd intrument readings on my 95

Evening everyone,

As I've mentioned here before I have a well used 95 GT 3000. It runs pretty well actually showing about 165K miles. Problems are mostly electronic, most of the rest has been worked on. Problems are the speedometer and tach aren't working. The tach shows a little motion when changing rpm but not much and not correct. The speedometer/odometer aren't working at all. I've looked through the service manual and it mentions a sensor on the engine but otherwise it's just checking things with a voltmeter. I'm going to plug it in and see if any codes pop up but nothing obvious comes to mind. I guess that's why we do all this stuff. Another odd issue is that it seems to be showing a low fluid level in the coolant. Not sure if it is the radiator or the tank but visual checking looks like there is plenty of coolant. It isn't running hot and the temps stay consistent. The rest of the instrumentation is working well and consistently. A car this old I'm not surprised at these problems or the slow moving drivers side window, the passenger side that has power but so far hasn't moved and I won't even talk about the sun roof. It's an older car, indifferently maintained and driven for fun I think. Carfax shows a lot of required maintenance done, things like timing belt service, oil changes and so on and no damage history. It's pretty clean for its age but I'd like to sort out the rest of it. Thanks.


Rick H.
f2shooter is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-02-2019, 01:35 PM
Super Moderator
 
Join Date: Oct 2008
Location: Alberta
Posts: 1,653
Probably air bubbles still stuck in the coolant.


Audio: JVC KD-ABT22 / JL sub+speakers / Sound deadening
Engine: WR-SRI / RRM 25% UDP / 6G75 TB
Other: RA Mudflaps
izerous is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mitsubishi-Forums.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome