Montero Sport starts then quits - Mitsubishi-Forums.com
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 08-21-2019, 06:21 PM Thread Starter
Newbie
 
Join Date: Mar 2016
Location: USA
Posts: 4
Montero Sport starts then quits

Yesterday I had a battery test to see if I had a dead cell, after the mechanic tried 3 times which kicked out his tester we then put in a new battery, the car now starts but quits right away. We shot ether into the air cleaner which kept in running for a short time. What did we burn out to keep the car running? The car is a 1999 Montero Sport XLS

Rear brakes

The rear brakes won't activate with the foot pedal. What is the problem?
Rod39 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mitsubishi-Forums.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome