2008 Lancer De Since July Of 2008 (or 07) - Mitsubishi-Forums.com
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 05-07-2015, 04:46 PM Thread Starter
Member
 
Join Date: Jul 2008
Posts: 31
Send a message via AIM to gearroc
Welp, it's been a while now, but I'm finally on the verge of hitting 100,000 miles!
Here's a quick update on what I've gone through in my 2008 Lancer DE.

NOTE: I'm not a hardcore modder; the only thing I touched was my intake and exhaust; I have DC Sports SRI, and Magnaflow axle-back. Did not tamper with any other part of the car.

1) Starting issues/bad battery? When I first bought the car, I had starting issues... the car would fail to ignite sometimes--completely randomized; no, it shouldnt be the weather, because I live in Los Angeles--the weather is usually 50-80 degrees F, all year. Dealer replaced the battery, but the problem was never resolved...

2) Gurgling issues at 3-4 RPM, since the 20,000 mile range. Always happens when the oil is past 3000-4000 miles... one time, my mechanic said he collected a quart of oil in my engine.

2) I did not have air conditioning for the first 5 years of the car, but I got an OEM one installed in 2012-ish. In 2014 I started to have gurgling issues; a mechanic told me that it may be a compressor issue.

3) At about 70,000 miles, my starter broke. I did not really do anything to it; one night, as I was getting ready to go home, it wouldn't start. Had to get it towed, along with a new starter.

So here are the problems that I had run into with my car. Hope this helps you guys in your knowledge of Lancers.

Anyone experience similar issues? Anyone have possible assumptions on my problems?

I'd like to know what you guys may have encountered with the car too.
gearroc is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-07-2015, 06:50 PM
Super Moderator
 
chain rattle's Avatar
 
Join Date: Jan 2006
Location: Ipswich Qld Australia
Posts: 4,065
Send a message via AIM to chain rattle Send a message via Yahoo to chain rattle


1) Starting issues/bad battery? When I first bought the car, I had starting issues... the car would fail to ignite sometimes--completely randomized;
. Dealer replaced the battery, but the problem was never resolved...

# Were coil paks /fuel line pressure /fuel filter inspected


2) Gurgling issues at 3-4 RPM, since the 20,000 mile range. Always happens when the oil is past 3000-4000 miles... one time, my mechanic said he collected a quart of oil in my engine.

# What grade oils have been used ..I would inspect and clean the EGR valve ..maybe hardend valve stem seals

2) I did not have air conditioning for the first 5 years of the car, but I got an OEM one installed in 2012-ish. In 2014 I started to have gurgling issues; a mechanic told me that it may be a compressor issue.

#air in the system check for leaks at all joins (0 rings ) and regas

3) At about 70,000 miles, my starter broke. I did not really do anything to it; one night, as I was getting ready to go home, it wouldn't start. Had to get it towed, along with a new starter.

# I would expect a starter to fail ....the starting problems early in its life hastened its demise

chain rattle is offline  
post #3 of 3 (permalink) Old 05-10-2015, 06:00 AM
Super Moderator
 
xrxaa01's Avatar
 
Join Date: Feb 2011
Location: Tanauan City
Posts: 1,402
<div class='quotetop'>QUOTE (GearROC @ May 8 2015, 04:46 AM) <{POST_SNAPBACK}></div>
Quote:
2) Gurgling issues at 3-4 RPM, since the 20,000 mile range. Always happens when the oil is past 3000-4000 miles... one time, my mechanic said he collected a quart of oil in my engine.[/b]

Does that mean he took out more oil than was supposed to be in the engine - or does it mean there was only a quart left ? Or something else ... ?

If he took out more - something is thinning the oil (water) - not good for engine.

If only quart left - you are burning oil and not checking oil level with dipstick - not good for engine.
xrxaa01 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mitsubishi-Forums.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome