Mitsubishi Forums banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi there, I'm having an issue with my hazard switch, which has caused problems with my indicators as well. The only way the indicators work is if you tap the hazard switch gently towards the on position, but not all the way. Then the indicators work, the hazards have never worked.

I have replaced the flasher relay and it wasn't part of the problem, even though the old one was reading a ludicrous ohm reading from what I could tell.

I pulled the hazard switch out from the dash, and tested it, and at least regarding continuity it's functioning correctly, so I went back to the ute and played around with it a bit - my result was that if I press the plug into the back of the hazard switch a bit more firmly, that it all functions properly, including the hazards which hadn't worked before.

My thoughts are, then that the plug on the wiring side is a bit worn and needs to be replaced. I think I have two ways to achieve this, either by hard wiring or using female adaptors to each of the pins in the hazard switch, or, if someone can help me identify the type of plug that's on the wiring side, that I can find a replacement and recrimp the whole thing. I tried searching up and down google for mitsubishi plugs, or generic automotive electrical plugs, or molex adaptors but I don't even know what it is that i should be searching for - and the parts lists I've found don't include the plug types.

Does anyone have any idea what the plug might be called? I'm fairly convinced the hazard switch itself is fine.
 

Attachments

1 - 1 of 1 Posts
Top