Mitsubishi Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Hello, as the title says, I have an RVR 2011 and the cooling fan doesn’t work when idling. This was brought to my attention when I had an hour and a half web meeting with the engine running when I noticed the engine to hot warning on.
A few hours later it was safe to turn on and drive the short distance home.

I took it into Canadian Tire and they told me the fuse was blown because both engine cooling fans were seized and quoted me over $1000 to fix. I took it home and discovered that the fans do in fact work when directly placed to the battery. They also worked whenever the gas is pressed.

I took it into the dealership today for a recall along with having them check it out. They ended up doing an AC recharge without my permission so that’s on them.

Does anyone have any suggestions as to the most likely source of this problem?

Edit: The dealership said that the electrical wiring and components are working as they are supposed to, except for both fan motors. They are saying that each fan only works when the full 12 volts are applied and won't work otherwise, so intermittently was their wording. Does that sound like something that is possible?
 

·
Super Moderator
2018 MQ Triton
Joined
·
209 Posts
Not sure about RVR, They are not imported into Australia, but there would be a relay in the system that would control fan operation. Does the fan come on with engine running and AC on?
 

·
Super Moderator
2018 MQ Triton
Joined
·
209 Posts
The fan should come on when the AC is turned on at all times, so you do have a problem then
 
1 - 4 of 4 Posts
Top