Mitsubishi Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I am still having this problem and was wondering if anyone had any suggestions. From time to time my Anti-Lock brake light comes on and stays on. Sometimes if i back down a steep hill and brake it will go off or if i pump brakes with engine off then start it they will disappear for a few days. I have checked the fluid,bled the brakes multiple times and even hooked a meter to the sensors on the wheels with no results. Please help if possible.
 

·
Premium Member
Joined
·
3,979 Posts
On systems with 4 wheel abs as oppossed to 2wheel on sum. The ABS modulator will need to be bleed itself. Not at the wheels. Most of the units have bleeder valves on them , a valve for each individual wheel on the ABS modulator . I have had this happen before , usually after sumone has replaced their brake pads , front and rear , or any kind of brake service.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
Sorry. The year is a 95 Montero SR. The light now stays on. I have pulled and cleaned the very dirty rear sensors but i could not get the front sensors out. There is only one bolt holding them on but they wont come out. Is there a way to run a diagnostics on the ABS? The light use to go out if i backed down a hill and applied the brakes, which tells me maybe the problem is the load sensing thing under the truck. I have bled the brakes including the middle thing many times. Any suggestions on how i can start diagnosing it? I have tested the sensors with my meter as per the manual instructions and had good readings. Could a poor seal on the master cylinder cause abs problems. My resevoir cap doesnt fit really great.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
I just had my front brakes completely replace hoping that my ABS light would go out. No luck. I have tested all of the sensors with an ohm meter as per my manual and they are all within the specifications. They have also been cleaned. I have also adjusted the load proportion valve spring to within specs as per my manual. Is there any other diagnostics i can do? The brake shop wants $80 an hour to try to find the problem. Thanks in advance.
 
1 - 6 of 6 Posts
Top