Mitsubishi Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
So 2 weeks ago we tried to get the timing belt fixed we did evrything right timing Mark correct and however it wont start it just cranks any sugestions?
 

·
Super Moderator
2018 MQ Triton
Joined
·
514 Posts
Did you reconnect the cranksensor?
 

·
Super Moderator
2018 MQ Triton
Joined
·
514 Posts
you need to check that you are getting a signal from the sensor when cranking the engine
 

·
Super Moderator
2018 MQ Triton
Joined
·
514 Posts
3 pins on the plug to the connector. 1 will be 5v reference signal, 1 will be earth and the other will have a voltage when cranking the engine so you will need a multimeter.. a cheap one will do
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
3 pins on the plug to the connector. 1 will be 5v reference signal, 1 will be earth and the other will have a voltage when cranking the engine so you will need a multimeter.. a cheap one will do
Hey thanks for the help reason I could nor reply back was that was busy with other stuff and so being what you told me found out that the sensor was bad reading less than 1v so my next question what brand should buy since the sensor is $123 usd + shipping for oe one
rock auto has different options like
ntk
wve(subsection of ntk)
beck arnley
holstein
I got no problem with buying the oe part but if I can get a reputable one for cheaper one would be nice and thanks for everything
 

·
Super Moderator
2018 MQ Triton
Joined
·
514 Posts
Did you have a 5v there as well?
 
1 - 8 of 8 Posts
Top