Mitsubishi Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello all, new to the forums. I am no mechanic by any means but do know how to do somethings. I am at a point that I am unsure what is wrong with this car. So lets dive into the details;

This is on a 2005 Galant with almost 210k miles. The fuel tank had a hole in it about a year ago, and was replaced with a used one. Once replacement was done the car would start and when you tried to drive it would die about a block later. Afterwards the car has been sitting up til now. A friend and I towed it to my house and we dived into checking as much things as we could think of. We have added Heet, and Seafoam to the gas as well as about 10 gallons of fresh gas and are getting good fuel pressure at the fuel rail. Initially we though it was the fuel pump but with it starting and the good pressure we no longer think this is the case. The car is throwing no codes after they were cleared from the original problems and there is no check engine light. We checked the plugs and wires they look brand new. All fluids are good and it has a new battery, also the air intake looks ok and operates as it should. The timing belt is a little weather cracked but all pulleys and belts seem to spin fine. So I thought maybe it has something to do with the TPS or throttle body but with no codes could this still be the cause? The car will start and idle but once you try to give it any gas it will sputter and cut out, also when revved there is a scratching noise or like something grinding that seems to come from under the car. Any ideas would be great as I would really like to get this car up and running. I'm sure there are some things I forgot to mention but will try to answer swiftly. Thanks for reading!
 
1 - 1 of 1 Posts
Top