Mitsubishi Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
hi to all
i have a mitsu colt 1990 model with a 4g61 engine the problem is that it has difficulties at starting in the morning when cold and when the engine does start and you rev the engine it sort of run like its chocking and you do not get a good acceleration.but once the engine is at its normal temprature its ok.can anyone help me with this problem.thanks in advance.
 

·
Premium Member
Joined
·
3,979 Posts
Fuel supply is important. Check yur fuel filter. As i have stated before , on these older Mitsubishi vehicles, the fuel pump was not regulated with a "prime" mode as later models and other vehicles to when yu turn on teh switch the fuel pump would cycle for 5-8 second and then on again when vehicle was running. These older systems the fuel pump onlee operated during engine cycle and running , ie only during the engines rotation cycle. The issue yu can be having is that yu have a severlly clogged fuel filter. What happens is after the car sits a period , being the fuel filter is clogged the fuel pressure either bleeds down thru the pump back to teh tank and back thru the fuel pressure regulator back to teh tank because the fuel filter is keeping an abnorminally high fuel rail pressure cause its clogged. So when yu try and start it when its cold there is no initial fuel pressure available to start the vehicle and the pump has to pump alot more pressure again during trying to start teh engine til it finally gets past teh filter to teh injectors. This is just a theory of wut may be going on but , it would exlain the car having normal drivability after initialy getting it started.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
thanks for your advice ill try n c through it cuz its true the fuel filter hasn't been change for a long time now ill try n c if thats the prob alrite.thanks a lot.
 

·
Registered
Joined
·
4 Posts
fuel system is important but i have the same problem with my 92 colt 200 gt. my fuel system is ok and i change many piceses in motor, plugs and spark plugs, rotor and distributor, coolant sensor, MAS air flow. etc.etc. but my problem is always in. i m check for a bad head gasket but i m not sure,

if your problem is repared, please contact me.
 

·
Premium Member
Joined
·
3,979 Posts
Wish i could be of more help, the onlee one that i had a similar issue like this . It had intermitten starting iussues and it was the ECU.
 

·
Registered
Joined
·
15 Posts
im on a few mitsu forums i dont think any colts are good when first started up ive had two and both had to sit for a while before happy they use loads of fuel and get choked up when cold
 
1 - 6 of 6 Posts
Top