Mitsubishi Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi,
I am a new Space Star owner in France. I accidently left the light on and found my battery dead.

I took the batery out and re-charged it, but after that, there is a piece sticking out on the speedometer that stops it from showing the speed.

Does anyone know how I can fix it?

The basturd delear in my town said he needs to change it and it will cost me 250 euros (290 dollars). Which is outragous.

I desperately need your help, because I am leaving to see my dream game at the world cup in Germany on Wednesday morning. I waited for 6 months for those tickets and can not afford to loose them and can not afford the 250 euro either.

My car is a Mitsubish Space Star 1.9 DID, of 2003 model.


Really appreciate your help,

/Farhad Abdolian
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Hi Dirty hands,
Thamks for the reply. I am 100% sure the cable is not broken.

Everything on SpaceStar is exlectronic, and the speedometer is bellow the 0 when I start the car, it goes to 0 when I ignite and then goes up to a place where there is a small pieces sticking up from the back of the speedometer that prevents it from working.

I am sure there is a trick to it, I was told I can reset the computer by taking the battery out for 20-30 minutes and see how it goes.

I will do it right away,

Best regards,
/Farhad
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Hi,
I did it, I just took the battery out for 40 minutes (while watching the second half of the Ghana-Italy game) and the car works like it was before.

Those **** can go to hell,

Thanks you guys, your site rocks.

/Farhad
 
1 - 4 of 4 Posts
Top