Mitsubishi Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi, the transmission on my '04 Endeavor Limited AWD (105k miles) is not shifting/engaging into anything, it's stuck in Park. Changing from Park to the Reverse, Neutral, Drive feels very loose compared to how it was before. Any clue what the problem is?

I haven't had any problems with my transmission/shifting/engaging before this. So this morning, I was parking and went up on a curb a little bit, all I remember is shifting to park and then when I tried to shift to anything else, it felt loose and even the P R N D on the dashboard is stuck on the green P and won't change to anything else. On a side note, I changed the oil with mobil 1 full synthetic and changed the filter myself a couple of weeks ago, I don't think this has to do with it but this is the only recent thing that's been done to it.

I'm still at work right now, I figure I'll get it towed later. Any clues as to what the problem might be? Where I should take it? Number of hours of overtime I'll have to work to get this fixed? etc..

Thanks for any help!
 

·
Registered
Joined
·
4,012 Posts
the shifter itself is whats loose?

or is it in the tranny?
 

·
Registered
Joined
·
1 Posts
I had that problem that turned out to be a cracked housing for the parking paw in the transmission. I ruined my shifter as a result of the parking paw problem and had to replace it too. The danger is replacing the shifter and not fixing the parking paw b/c the car will pop out of park on an incline and roll. 2008 Endeavor.
 
1 - 4 of 4 Posts
Top