Mitsubishi Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
Hello,
I have a 97 Carisma GL and just recently the heater controls have started to malfunction.Its just the heater power control thats not working correctly,normaly you would have 4 different speed setting on the heater,but only the third setting on my heater is working.Does any one know what could be causing this,I would really appreciate some help.Thanks.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #2 ·
Does any one know where the blower motor is under the bonnet.I have read somewhere else it could be a Ceramic resistor that needs replacing?
 

·
Registered
Joined
·
9 Posts
Ha... I got this exact same problem and thought that maybe it was unique.

Any other ideas on what it can be?

And where is this ceramic resistor you speak of?
 

·
Registered
Joined
·
109 Posts
<div class='quotetop'>QUOTE (LeeBoy @ Jan 18 2010, 04:50 AM) <{POST_SNAPBACK}></div>
Ha... I got this exact same problem and thought that maybe it was unique.

Any other ideas on what it can be?

And where is this ceramic resistor you speak of?[/b]

WTF.. I didnt really get it. So the temperature works but not the speed? (Only 3rd speed works)
Oh well, since i didnt really get it here is my advice: Check fuses inside the car + under the hood

And then after that if i were you i would dismount the heater control and check that everything is working properly and clean it if needed...
 
1 - 4 of 4 Posts
Top