Mitsubishi Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi guys,

I have a 2006 1.6 litre petrol lancer that's had idle problems since getting it about 6 weeks ago (wrote off my last one about 6 weeks, flipped her in ice.).

Anyway since I got it I'm getting the code p0505, idle air control system malfunction.

She Idles around 1800-1900 cold and drops to about 1500 when hot. I've swapped the iac with my other lancer that never had an idle problem with no change. I've checked tps, reading I believe about 0.6v closed which is correct. I've cleaned the throttle body and iacv with no change. I cannot detect any leaks anywhere.

Pulling the iacv connector idles up around 3000. Blocking the hole on the bottom of the throttle body for the iacv drops the idle to 1000, can't hear or feel air getting in past the plate. Now if I unplug the map sensor with iacv blocked idle reduces to about 900, if I unplug map with the iacv hole open the idle raises. Cannot locate a maf sensor on my air intake anywhere, should I have one or the 1.6 just uses the map?

Also blocking the pcv lowers the idle but the valve appears to be working correctly.
Maybe some of what I've tried is nonsense but said I'd post all my findings in hope of a fix, I was thinking of changing the throttle body but the plate seems fine on this so I'm reluctant to do so. Any other ideas of what my problem is would be very welcome.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
All sorted, butterfly plate wasn't closing fully, adjusted the screw below where the cable attaches to the body and my idle is now fine.
 
1 - 2 of 2 Posts
Top