Mitsubishi Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I've got a motor from a 2003 Galant, 4cyl 2.4l that just started some kind of ticking noise on the passenger side. We thought it was lifters and just replaced any we found to be bad and its still ticking. Also took the rockers and rocker arms from a previously non ticking engine and its still ticking. Anybody know what else this ticking noise might be?
 

·
Registered
Joined
·
5 Posts
I think i have the same issue as you. I can hear the ticking mostly through the passenger wheel well, it more abundant in that specific area. Personally in about 3-4 weeks i will do a coolant flush, or several of them to be precise. Im sure the cooling system is fine for you but mine is bad and i could only imagine if my engine was clean how much better it will perform. Money is an issue so she sits for now, definitely cant wait and will share my experience, will be my first time doing a flush. Also made a post a while back about a P0300 random misfire i had(rough idle). i solved the issue it was a bad distributor. Popped the new one in and she purred.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
I think i have the same issue as you. I can hear the ticking mostly through the passenger wheel well, it more abundant in that specific area. Personally in about 3-4 weeks i will do a coolant flush, or several of them to be precise. Im sure the cooling system is fine for you but mine is bad and i could only imagine if my engine was clean how much better it will perform. Money is an issue so she sits for now, definitely cant wait and will share my experience, will be my first time doing a flush. Also made a post a while back about a P0300 random misfire i had(rough idle). i solved the issue it was a bad distributor. Popped the new one in and she purred.
Ended up discovering that it was a bad balance shaft bearing, one of the 3 bearings had practically disintegrated leaving the balance shift to kinda wobble around inaide the engine, hence the ticking sound.
I would check your oil pan for metal
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
I think i have the same issue as you. I can hear the ticking mostly through the passenger wheel well, it more abundant in that specific area. Personally in about 3-4 weeks i will do a coolant flush, or several of them to be precise. Im sure the cooling system is fine for you but mine is bad and i could only imagine if my engine was clean how much better it will perform. Money is an issue so she sits for now, definitely cant wait and will share my experience, will be my first time doing a flush. Also made a post a while back about a P0300 random misfire i had(rough idle). i solved the issue it was a bad distributor. Popped the new one in and she purred.
Think the balance shafts are visible from inside the pan too, once the pan is dropped
 
1 - 4 of 4 Posts
Top