Mitsubishi Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi guys,

I'm not trying to hang [email protected] on the Lancer here, but I bought my wife a brand new '07 Lancer ES wagon at the start of this year and have almost regretted it since.

As I was driving it home from the dealer after purchasing it, I found it constantly jumped out of 1st gear. Even trying to hold the stick in didn't work. Took it straight back to the dealer who said to wait and let it settle in for a while. Gave it until the 1500km check up and had 1st gear synchros replaced. Ever since then 1st and 2nd are both difficult to find.

Now at low revs it has no response. The engine doesn't pick up revs until throttle's half open position which causes a shocking launch forward which has nearly caused a couple of accidents. Had it checked to see if the TPS on the drive-by-wire was set incorrectly. Mitsubishi mechanic took it for a spin to check it out. It did it that bad it nearly rear ended the dealerships Evo IX which was in front of us. He just looked at me and said "whoa that was close" and laughed. He said it was basically a common fault with the newer Lancers and a lot of them across Oz are doing it and that we'll just have to get used to it as it's within specifications. That's great but it's my insurance that pays for any damage this little 'model specific fault' causes.

My other car is a 5L V8 Ford TE50. We bought the Lancer as a fuel saving measure but have found that on a highway we're better off with the V8 as it matches (and occasionally outdoes) the Lancer for fuel economy. Can only justify itself around city driving.

I'm not sure if we've just scored a lemon, which I doubt as we test drove a few from different dealers before we bought one which had similar faults. Just put it down to they were demo cars and got flogged from time to time. I know of one or two others that have the '06 and '07 Lancers and the also report similar concerns.

I'm just curious if anyone here has had these problems with their cars and if so what they have done to fix them. Again I'm not here to bag out these cars, just trying to learn a little more about them.

Cheers guys.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #2 ·
All of the previous problems are still constant plus the added bonus of the car feeling like it's misfiring all the time. However, I'm finally starting to get to the bottom of this. Turns out a large number of CH Lancers are showing the same problems as ours. Mitsubishi Australia believes there is a problem with the air/fuel mixtures and are waiting for Mitsubishi Japan to acknowledge the problem and provide a program to reflash the ECU.

Apart from that there is now a constant rubbing noise coming from the front, used to only happen when slowing down but now occurs all the time and gets worse at higher speeds. The only common fault ours isn't showing (yet) is that the MP3 headunit in the '07 model is known to just shut down. We're waiting for it though.
 
1 - 2 of 2 Posts
Top