Mitsubishi Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
here's the problem. i have an '05 with about 9,000 miles. inbetween 3,500-4,000 miles, the oil light started coming on. it only comes on after i've been driving for awhile, and comes on when i'm at a stop. when it does come on it flickers of and on, and the car idles alittle rough. i've taken it to the dealer and the say they can't find anything wrong with it. now has anybody else seen this or i'm i the only one with this problem? :liebe011:
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
thanx, for the info. i'll have to see if the dealer will warranty it, since it doesn't do it when i've taken it in to be checked.
 

·
Registered
Joined
·
1 Posts
I'm here for the same reason, researching the problem with the flickering oil light in a 2005 Galant. The dealer said the computer was just resetting itself. HA! A mechanic that we asked checked with another Mitzu dealership, and they said nothing was reported with Mitsubishi. They also told us to keep going back to our dealership until they fixed it.
 

·
Registered
Joined
·
3 Posts
Im having a similar issue with a 03 Galant, noticed the light flash the other day when I turned on the fan. The acted as if it wanted to shut off, but once the fan was off the light stopped flashing and the car was fine. The issue only occurs when the car is stopped. Any ideas? Looking to save money with the car approaching 60,000 miles there is no warrenty and I still have to have the 60,000 mile conversion done (timing belt and spark plugs).
 

·
Registered
Joined
·
2 Posts
here's the problem. i have an '05 with about 9,000 miles. inbetween 3,500-4,000 miles, the oil light started coming on. it only comes on after i've been driving for awhile, and comes on when i'm at a stop. when it does come on it flickers of and on, and the car idles alittle rough. i've taken it to the dealer and the say they can't find anything wrong with it. now has anybody else seen this or i'm i the only one with this problem? :liebe011:
 

·
Registered
Joined
·
2 Posts
I also have this problem.Today I did an oil change & oil filter change but this has not fixed the oil light.
I'll order a new sensor & get the old one off & hopefully this will sort it.
 
1 - 9 of 9 Posts
Top