Mitsubishi Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Hello everyone i got this issue this time with my cvt.
When moving from 0 to 15 mph cvt makes a noise i cant described but maybe grouwl i can hear it more if i depress the gas pedal.
But after 15mph the noise goes away and cvt if pretty quiet driving after 15mph and shift and run perfect.
Maybe a wheel bearing?i replaced the cvt fluid twice because it was really bad dark brown only way to tell is brown is if you shine a light to it.the curious part it that noise was not heard before oil change.any help to pinpoint what could it be the issue or if is normal since i havent find any post with the same noise.
 

·
Super Moderator
2018 MQ Triton
Joined
·
514 Posts
What oil did you use to refill the CVT?
 

·
Super Moderator
2018 MQ Triton
Joined
·
514 Posts
What colour is the oil?
 

·
Super Moderator
2018 MQ Triton
Joined
·
514 Posts
And you said the old oil was brown, maybe it had previously been filled with incorrect oil? without hearing the noise it is hard to guess
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #7 ·
And you said the old oil was brown, maybe it had previously been filled with incorrect oil? without hearing the noise it is hard to guess
Ok i will be replacing the oil twice again eneos is ok?is a little cheaper than mitsubishi
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #9 ·
Is an alternative that most users on nissan forum recommend for oem nissan fluid.
Since what i read is true that mitsubishi cvts are the same as nissan both uses the same cvt that's why i ask first if is ok that oil this is my first car with cvt and on the internet people makes it look that this type of transmission are the worst to have on a car.
 

·
Super Moderator
2018 MQ Triton
Joined
·
514 Posts
They do have problems, but the ones i have seen have either been fixed under warranty due to a manufacturing defect, or the problem was caused by mechanics putting the wrong oil in the trans, which is why i asked about the colour.

If the oil has any red in it it is likely contaminated by the incorrect oil. As the correct oil being green/blue will not go red, but rather dirty brown with severe overheating
 

·
Registered
Joined
·
2 Posts
Hello everyone i got this issue this time with my cvt.
When moving from 0 to 15 mph cvt makes a noise i cant described but maybe grouwl i can hear it more if i depress the gas pedal.
But after 15mph the noise goes away and cvt if pretty quiet driving after 15mph and shift and run perfect.
Maybe a wheel bearing?i replaced the cvt fluid twice because it was really bad dark brown only way to tell is brown is if you shine a light to it.the curious part it that noise was not heard before oil change.any help
Hello everyone i got this issue this time with my cvt.
When moving from 0 to 15 mph cvt makes a noise i cant described but maybe grouwl i can hear it more if i depress the gas pedal.
But after 15mph the noise goes away and cvt if pretty quiet driving after 15mph and shift and run perfect.
Maybe a wheel bearing?i replaced the cvt fluid twice because it was really bad dark brown only way to tell is brown is if you shine a light to it.the curious part it that noise was not heard before oil change.any help to pinpoint what could it be the issue or if is normal since i havent find any post with the same noise.
to pinpoint what could it be the issue or if is normal since i havent find any post with the same noise.
It may be a bearing. Does it get worse or better with turning the wheel? It may be like a stopped up catalytic converter but not likely. Maybe a throw out bearing
 
1 - 11 of 11 Posts
Top