Mitsubishi Forums banner
1 - 6 of 6 Posts

·
Administrator
2021 MR Triton
Joined
·
676 Posts
Can you give us some more information.

Year?

Engine code?

Does it normally start ok?

recently serviced?

Any repairs done recently?

Does it make any noise at all?

Does the engine spin turn over as normal?

Does it just make a clicking sound?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Can you give us some more information.

Year?

Engine code?

Does it normally start ok?

recently serviced?

Any repairs done recently?

Does it make any noise at all?

Does the engine spin turn over as normal?

Does it just make a clicking sound?
Hi, thank you for your reply. The car is 05, engine code is 4g69, originally it did start but wouldn't run.
It hasn't had a service under my ownership. it hasn't had any repairs recently. the engine turns over on the starter motor. there is no clicking sound. 76000 miles believed genuine, a really sweet engine when it did run.
 

·
Administrator
2021 MR Triton
Joined
·
676 Posts
Its hard to say without hearing it. There are so many things it could be. Are you with the AA or RAC?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Its hard to say without hearing it. There are so many things it could be. Are you with the AA or RAC?
Its hard to say without hearing it. There are so many things it could be. Are you with the AA or RAC?
Thank you for your prompt reply. No, I don't do AA or RAC, Could you tell me the common faults regarding this engine. would it be fuel, ignition (electrics), or immobiliser? Or variable timing problems.
PS. I grew up with series Land Rovers, so excuse my ignorance.
 

·
Registered
Joined
·
3 Posts
Start with the simple things first. Fuel pump fuse, fuel injection fuse. Pull the ignition coils off and see if the plugs are dirty. Are there any fault codes when you plug a scan tool in?
 
1 - 6 of 6 Posts
Top