Mitsubishi Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello, i have a 2003 Lancer ES with the 2.0 auto. About a month ago i noticed it started getting really sluggish about 30 mins into driving, as of last week it gets sluggish as soon as the temperature gauge is off the C. Its parked, i try not to drive it as much as possible to prevent damage. I need help identifying the problem. I bought it without a muffler over a year ago and havent had any problems until now. It does have a cold air intake. I drove it 4 miles the other day, when i got out i noticed the exhaust after the headers was cherry red. I drove casual, no flooring, nothing. Coolant starts bubbling after 10 minutes of idle in 25ish degree temperatures. It does not blow any smoke, just gets very sluggish and warms up fast. The temp gauge never goes up more than half. When i start it i have to keep the idle at 2,000rpms or it will die. Once idled and starting to warm after about 1 minute of throttle it will idle (with a lope once warmed up) by itself. It will run strong for the first 5 minutes and then gets really sluggish. At red lights it gets jerky. No matter how hard the brake pedal is down it tries to go and stops in motion with the lope from the engine. When letting the car move under its own power without me touching the throttle it moves strong, then stops, then strong, then stops. Once again, in motion with the lope. Just to mention ive had to replace both belts twice within 1000 miles. Ive tried a coolant flush, both fans work, heat and a/c work strong. I have a new water pump but dont want to start messing with timing if its unneeded. Im getting clueless. I was thinking maybe clogged cat as it is cut a foot past the end of cat? Maybe water pump? Im not sure. Any help would be much appreciated. Can provide video and pictures.
 
1 - 1 of 1 Posts
Top