Mitsubishi Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My alternator gave up I replaced the regulator on it and it stil doesn't charge also I tried 2-4 other alternators and they don't work I'm not sure if my 4g93 engine has a computer and if it does where is it located so I could try to fix this issue
 

·
Registered
Joined
·
2 Posts
My alternator gave up I replaced the regulator on it and it stil doesn't charge also I tried 2-4 other alternators and they don't work I'm not sure if my 4g93 engine has a computer and if it does where is it located so I could try to fix this issue
Check the fusible link on positive battery cable. It might be a pack connected to the battery post. If that fuse is blown it will not charge the battery.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
when you turn on your ignition before you start does the battery light show?
when you turn on your ignition before you start does the battery light show?
Sorry for the late response my email has been acting up but yes the battery light usually shows up
Check the fusible link on positive battery cable. It might be a pack connected to the battery post. If that fuse is blown it will not charge the battery.

Will do sorry for the late response
 

·
Registered
Joined
·
109 Posts
With the engine running, give the alternator a whack with a hammer, this can shock the brushes loose and cause them to contact the armature again. If this works you will need new brushes at the least, and possibly an armature clean or repair, which would probably mean new alternator as cheaper
 
1 - 6 of 6 Posts
Top