Mitsubishi Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Several problems have surfaced recently, approximately at the same time. I am getting a rattling or pinging noise on moderate acceleration just at the point where it is about to shift to the next gear. When taking it easy on the gas, the noise is not heard - nor is it heard on heavy acceleration. I've heard pre-ignition knock before in previous cars, and this does not really sound the same. In addition, the check engine light has come on. Last, but not least, the rear widow and hatch latches have gone crazy. The window will unlatch all by itself. It will usually latch again for some short period of time, but sometimes will not latch at all. When this happens, if I am quick enough on closing the window and quickly open the entire hatch, the window will stay latched (quess that there is an interlock that prevents both being open at the same time) and then close the hatch, the window will then stay latched again for some period of time (minutes - hours) before popping open again. Sometimes both the window and the hatch are latched and neither will open without cycling through the lock-unlock sequence. Could all of these problems be somehow related? I'm at a loss. Thanks for any info.
 

·
Registered
Joined
·
1,157 Posts
there are plenty of posts regarding pinging on endeavors (especially the 04s).
you should do a search.
the other issue is a new one to me, and will require a professional diagnosis.
 
1 - 2 of 2 Posts
Top