Mitsubishi Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2004 Endeavor with 40k miles. For the last 10k miles, there has been a squeaking noise coming from the front end while braking. I have had it to the dealership 3 times, but they have been unable to locate the probem.

The problem only occurs during the end of the stop. You can hear the noise say from 10 MPH and below.

Also this only happens during a normal stop and not during hard braking.

Also when it is raining the noise does not occur.

Has anyone had this problem or have any ideas to the cause?

Thanks
 

·
Registered
Joined
·
13 Posts
I work on heavy trucks and most of the time we find that the pads or shoes are glazed over from getting hot once upon a time. The only way to realy fix it is using a grinder to buff the surface of the pads.
 

·
Registered
Joined
·
499 Posts
try having your pads taken out and chamfer the edges.this is a very easy mod and generally stops all low speed noise although most new pads nowadays are of such a hard composition that low speed squeal is unavoidable from cold until the materials get warmed up.the newer material are designed for better performance braking and generally not so good cold
 

·
Registered
Joined
·
16 Posts
2004.5 LS AWD
I get a clunking clipping noise at low speed forward & reverse when brakes are initally applied, thought also the pad but had brake pads replaced (with factory OE at dealer) and then they lubed still same problem

water acts as lube so you won't have the problem then

this time had brakes done at a reputable shop (ASE Master Tech) and used EBC Green Stuff for more stopping power (braking only slightly better) on both front & rear

noise went away a little more, thinking its the calipers or other suspension
 
1 - 4 of 4 Posts
Top