Mitsubishi Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I just bought my 06' Mitsubishi Galant. 4000 miles on the clock.

-The SRS Light is on solid red on the dash.

-The horn doesn't work

-When the passenger seat is occupied, and the seat belt is latched - the light on the dash still illuminated to show that the passenger seat belt is not latched.


I've called the dealership - but they need to set up a time for me to come in. Any ideas before I go in?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #2 ·
Wow...no responses?

Sheesh.

I haven't called the dealership yet, as I've been quite busy.

No ideas?

I'm installing two 7 inch screens in my head rests, in which case I'll need to disconnect the battery - so I guess we'll see how that goes.
 

·
Registered
Joined
·
1,157 Posts
Originally posted by Kyle06Galant@Sep 10 2007, 11:08 AM
Wow...no responses?

Sheesh.

I haven't called the dealership yet, as I've been quite busy.

No ideas?

I'm installing two 7 inch screens in my head rests, in which case I'll need to disconnect the battery - so I guess we'll see how that goes.
[snapback]111590[/snapback]​
no one answered because no one can.

nobody here can tell you whats the matter with your car. Only the dealership will be able to do that.
 

·
Registered
Joined
·
11 Posts
If I were to guess... I would say that the clockspring in your steering column was bad or that there was a problem with its connection into the wiring of your car.

That doesn't really explain the seatbelt thing, so maybe check for any disconnected wires... Do you have cruise control buttons on the wheel? do those work at all?
 
1 - 4 of 4 Posts
Top