Mitsubishi Forums banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Ok, this has been a plaguing mystery, and it has left me stranded on more than one occasion. I can't pinpoint exactly what the issue is, but I'm going to explain it on here as best as I can with as much detail as I can because I am desperate to find out what needs to be fixed. When I first experienced this problem, I was taking a right turn out of the parking lot of the place I work for as a delivery driver. The car got up to about 2,000 RPMs or so, and then I felt an extreme jerk and hesitation. Once this occurred, I couldn't even get the vehicle to get up to a 1000 RPMs, and often when I would hit the gas either nothing would happen at all or the revs would actually decrease. Additionally, anytime I would try to rev the vehicle, it would do different things. Sometimes it might go up to 3 or 4,000 RPMs, and then a bit of a loud noise and then the power would continue to go back down even if I had the accelerator on the floor. And anytime I would try to operate the vehicle in drive, it would just sputter and jerk erratically, and I would occasionally hear what sounded like a knocking sound coming from underneath the car. That was the first time it ever occurred. I took it to my mechanic shop and had to leave it there overnight. But when my mechanic drove the vehicle, the problem did not occur so he had me come pick my car up, rather than just charging for the labor of continuing to wait and look at it. So then the problem didn't occur for a good little while, even with running it 5 days a week as a delivery driver. So then I had the problem occur on me again in the middle of one of my delivery shifts. Same issue, no revs when hitting the gas, or it basically decelerating to less than 500 RPMs. However when I left the car engine turned off for a few minutes, it seemed to do okay after that. And that has been the story thus far. But the most recent time this occurred which was only a few days ago, there were a couple of times that when I restarted the vehicle the revs were so low it would just die. And whatever the problem is it's causing some kind of knocking around or clanking sound. I want to take it in and get it fixed, but it's hard to explain unless the problem is occurring. If I take it to the mechanic and the problem does not occur, they will just tell me there is nothing they can do. I do have the check engine light on, but when I got that scanned it was related to the evaporative emission system. I want to say that it's throttle related, but from what I've been able to research, I don't match up with a lot of the symptoms of a bad TPS, or bad throttle body, or bad catalytic converter, etc. And ever since the problem occurred most recently, it seems that the way the engine runs in general gets worse. I've only gone short distances in fear of this problem stranding me. I don't understand what causes this issue to occur in the first place, and I never know when or what conditions can cause it. If someone has experienced this kind of problem, or if more details are needed, please reply to this and I will try to give as much information as I can.
 
1 - 1 of 1 Posts
Top