Mitsubishi Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I have a 2007 AWD Endeavor with only 2K miles on it. Everynow and then I notice the car bucks when stepping on the accelerator. Felt like the transmission wanting to shift up, but instead got shifted down. A momentary jerking movement. The last time this happens (last wk), I felt like the car got pulled back as it tried to lunge forward.

Does anyone experience this or am I the only one. Is this normal or something I need to bring into the dealer. It happens so rarely that I'm afraid if I bring into a shop, the mechanics would think I'm imagining things.

Please help
 

·
Registered
Joined
·
39 Posts
I think I may know what you're feeling. My '04 does kinda the same thing. I would describe it as "bucking". It usually happens whenever I really jam on the accelerator, going up hill. I never thought much about it cause it only happens when i'm mildly abusing the car. I think its just cause I'm trying to make the car shift faster than it can. The Endee has a lot of torque. But maybe this is totally different than your situation.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
Thanks TLindh373,
I think we have the same "problem" or observation. You just described exactly what I experienced with my Endeavor. As you pointed out, it may not be a real "problem", but just an engineering glitch that Mitsubishi didn't foresee when they put 253 lbs-feet of torque into a 4-speed automatic transmission. Thus shifting won't be very smooth. Just as you said, I experience this "bucking" phenomenon when I step on (or let go) the gas pedal too sudenly.

I'm surprised that only me an TLindh373 are the only 2 people who notice this "strange behavior" of the Endeavor.
 
1 - 4 of 4 Posts
Top